75年生人,程序员,在西安。

被re-frame的版本变化坑惨了

re-frame 0.7.0 方法名是

  • register-handler

  • register-sub

re-frame 0.8.0-alpha9 方法名是

  • reg-event

  • reg-sub

结果,re-frame 0.8.0 用这两个方法名报错:

console.error: "goog.require could not find: re_frame.registrar"

原来 re-frame 0.8.0 应该是:

  • reg-event-db

  • reg-sub

编程工具的选择

几款先进的编辑器比较

SitePoint Smackdown: Atom vs Brackets vs Light Table vs Sublime Text

个人更喜欢Atom一些,好像缺点就是大文件编辑有点慢……

因为对 Lisp 语言的简洁非常喜爱,所以最近在研究 Clojure,结合 Atom 来编程很是舒服,另外,发现个牛叉的 Parinfer 技术,真的是:妈妈再也不用担心括号不匹配了!哈哈……

Clojure 中有没有 Actor 这样的框架?

今天想到这个问题,搜了一下有两篇文章相关:

有没有人用Clojure写了类似 Actor 这样的框架?或者说Clojure中有其他类似的甚至更好的解决方案替代Actor?

© 世风十三 | Powered by LOFTER